Clean Code that Works.

Java 8을 제대로 쓸려면 이클립스 4.4를 써야...

지금 쓰고 있는 버전이 STS 3.6.1(eclipse 4.3)이었는데 JDK를 Java 8로 바꿔서 사용할 경우 Comparator를 구현한 클래스에서 Java 8에 새로 추가된 Default 메서드도 구현하라고 컴파일 에러를 만들어 준다.


그래서 eclipse 4.4가 포함된 sts 3.6.1로 바꿨더니 안나옴.
서버 목록에 tomcat 8도 추가 됨.
메뉴에 몇몇 아이콘 들이 추가 됨.

다른 기능들은 한번 보면서 찾아 봐야겠다.


신고

Comment +0

티스토리 툴바